Some Assets Are Not Loading Properly for Users Within Specific Regions

Incident Report for Showit

Resolved

The issue causing regional issues for some customers has been fixed and resolved.
Posted Feb 04, 2026 - 23:45 MST

Update

Customers from specific regions are having issues loading fonts, images, and other assets.
Posted Feb 04, 2026 - 20:02 MST

Investigating

We are currently investigating the issue
Posted Feb 04, 2026 - 18:30 MST
This incident affected: Application Services, Blog Hosting, and Website Hosting.