Partal Blog and Site outage

Incident Report for Showit

Resolved

The affected servers should be up and running and the issue is now resolved.
Posted Sep 02, 2025 - 23:04 MST

Identified

Our small batch of scheduled blog maintenance is still taking longer that originally anticipated. We hope to have everything wrapped up shortly. We will update once we know more.
Posted Sep 02, 2025 - 22:11 MST
This incident affected: Blog Hosting and Website Hosting.