Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 20:00 MST
Scheduled
A small portion of our users may experience downtime as we update our blog infrastructure. We expect that the maintenance may result in up to 30mins to 1hr interruption of service to your sites during the server update/upgrade.
Posted Dec 09, 2025 - 16:08 MST
This scheduled maintenance affected: Blog Hosting and Website Hosting.