Partial Service Outage
Incident Report for Showit
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 18:38 MST
Investigating
Our hosting partners at WPE Engine are investigating an issue impacting thier US Central data center. You can view their progress here:
https://wpenginestatus.com/

Some Showit sites and blogs may be affected at this time
Posted Dec 05, 2023 - 16:14 MST
This incident affected: Blog Hosting.