Service Disruption (Upstream Provider Issue)

Incident Report for Showit

Resolved

AWS has restored service
Posted Feb 10, 2026 - 15:52 MST

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2026 - 14:57 MST

Identified

We are currently experiencing intermittent connectivity and DNS resolution issues affecting the design app. This is due to an ongoing AWS CloudFront operational incident causing increased error rates and latency across multiple AWS services.

AWS has reported early signs of recovery, and we are actively monitoring the situation.
Posted Feb 10, 2026 - 14:57 MST
This incident affected: Application Services.