Partial Service Outage
Incident Report for Showit
Resolved
This issue is resolved and normal function should have returned to all users across the platform. Please reach out to Showit Customer Support if you are experiencing any further unusual issues. Thank you.
Posted Jun 13, 2023 - 16:23 MST
Monitoring
A fix has been implemented for this issue, some users may still experience residual issues for a limited time. We are monitoring the situation to insure the issue is resolved.
Posted Jun 13, 2023 - 14:09 MST
Identified
The issue has been identified involving our AWS hosting servers. You may experience issues with publishing, uploading media, and slow processing speeds. We are working to resolve this issue and will update this status page accordingly. Thank you.
Posted Jun 13, 2023 - 12:52 MST
This incident affected: Application Services.