Customer Support Chat Function Interruption
Incident Report for Showit
Resolved
It appears that the issue with the third party that powers our support chat has been resolved. Normal function should now resume. Thank you for your patience.
Posted May 29, 2024 - 09:30 MST
Monitoring
The third-party tool we use to manage our in-app support chat is currently experiencing issues. They have identified a fix and are working on a resolution. The ability to reach Showit Support is currently diminished and we will be ready to assist you as soon as this system has restored functionality.
Posted May 29, 2024 - 08:58 MST
This incident affected: Application Services.