Degraded Servives

Incident Report for Showit

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:50 MST

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 11:02 MST

Investigating

Due to ongoing issues with AWS our users may experience degraded and limited services over the next few hours. We are monitoring the situation and will update accordingly.
Posted Oct 20, 2025 - 10:50 MST
This incident affected: Application Services and Website Hosting.