Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2025 - 22:00 MST
Scheduled
We will be performing a system database update, during which users will not be able to edit their Showit websites or log into your account at account.showit.com . This maintenance is necessary to ensure optimal performance and security.
Your website will remain online during this upgrade process.
We appreciate your patience and will restore full functionality as soon as the update is complete.
Posted Feb 27, 2025 - 11:04 MST
This scheduled maintenance affected: Application Services.