Partial Blog and Site Downtime

Incident Report for Showit

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 18:15 MST

Investigating

A very small portion of our users may be experiencing downtime on our blog hosting
Posted Jan 22, 2026 - 17:53 MST
This incident affected: Blog Hosting and Website Hosting.