Blog Plugin Update Issues
Incident Report for Showit
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 10:24 MST
Investigating
Our wordpress hosting partners at WPEngine have informed us of an issue with the ability to add, remove, and update plugins. This does not impact any content or posts changes. More details can be found here: https://wpenginestatus.com/incidents/640187

We will update this page once more information is available.
Posted Sep 25, 2024 - 15:13 MST
This incident affected: Blog Hosting.